Search found 4 matches

by mefisto112
05.04.2007, 14:25
Forum: Feature Requests
Topic: Delphi7 + Zeos + MySQL : Unicode doesn't work
Replies: 6
Views: 3530

Added uses utf8vcl and now everything seems to work: http://sourceforge.net/projects/utf8vcl/
by mefisto112
05.03.2007, 13:52
Forum: Feature Requests
Topic: Delphi7 + Zeos + MySQL : Unicode doesn't work
Replies: 6
Views: 3530

If I add in ZConnection.Properties the string CodePage=UTF8 and I read data using UTF8Decode the UTF8 values from MySql are corrects but I can't still write them with the corresponding UTF8Encode. And most important, in MyDac everything works fine (without need of conversions) only setting MyConnect...
by mefisto112
01.03.2007, 11:20
Forum: 6.5.1 (alpha) - 6.6.x (beta)
Topic: Problems with UTF8 in ZeosLib 6.5.1
Replies: 6
Views: 1519

I have the same problem with 6.6.1 version and CodePage=utf8. Where do you put UTF8Encode / UTF8Decode functions? If I try WideShowMessage(UTF8Decode(TntDbEdit1.Text)) it works, but i want populate ZTable and ZQuery with corrects values and also write to MySQL utf8 fields! Perhaps ZeosDevTeam can pr...
by mefisto112
28.02.2007, 20:31
Forum: Feature Requests
Topic: Delphi7 + Zeos + MySQL : Unicode doesn't work
Replies: 6
Views: 3530

Delphi7 + Zeos + MySQL : Unicode doesn't work

Hi all, in my Delphi 7 project I have a TntDBGrid (http://www.tntware.com/delphicontrols/unicode/) connected to a ZConnection connected to a MySql5 database with some UTF8 fields. I can't see and write correctly the characters out of standard ansi (i.e. Russian). If instead of ZConnection I use MyDa...

Go to advanced search