Search found 15 matches

by gmb
24.04.2013, 06:19
Forum: 6.6 - stable
Topic: Postgres 9.2 UTF: single quote posted as '\047'
Replies: 0
Views: 589

Postgres 9.2 UTF: single quote posted as '\047'

Apologies, I know there are many posts out there on this subject, but tried a lot of the suggestions and still cannot get this right. If someone can point me in the right direction, I'll appreciate it a lot. I'm using Delphi6, ZEOS v 6.6.6, PostgreSQL 9.2 (DB encoding = UTF8) Posting a string value ...
by gmb
30.08.2011, 23:04
Forum: 6.6 - stable
Topic: Getting out of transaction if exception occurred
Replies: 5
Views: 583

Thanks for the response, Wild_Pointer (and sorry for my late reply) I've read some articles about AutoCommit, but cannot quite understand what effect it will have on my code. As far as I understand, setting this to TRUE will mean that each statement is committed automatically, which negates my goal ...
by gmb
25.08.2011, 06:51
Forum: 6.6 - stable
Topic: Getting out of transaction if exception occurred
Replies: 5
Views: 583

Getting out of transaction if exception occurred

Hi there Using Zeos 6.6.6-stable with Delphi6 on Postgres 8.3 I'm having difficulty implementing transactions in my application in the way that I feel will be most practical. My app is running lengthy DB processes which I'd like to put in transactions; I've implemented it like this: ExecSQL( 'begin;...
by gmb
11.11.2010, 10:05
Forum: 6.1.5
Topic: Postgres sequence problem after DB restore - Help please
Replies: 12
Views: 1905

THanks mdaems,
I'll have a look at ver 6.6 then.
Regards
by gmb
09.11.2010, 10:23
Forum: 6.1.5
Topic: Postgres sequence problem after DB restore - Help please
Replies: 12
Views: 1905

7.0.0-alpha is the first experimental release which should make zeoslib usable on Delphi 2009 and Delphi 2010. Support for Delphi versions older than Delphi 7 has been removed.

Guess this means I'm stuck with pre ver 7 versions as I'm using delphi6
by gmb
09.11.2010, 10:18
Forum: 6.1.5
Topic: Postgres sequence problem after DB restore - Help please
Replies: 12
Views: 1905

Wild_Pointer
I'll check it out,
Thanks again for your help
by gmb
09.11.2010, 09:05
Forum: 6.1.5
Topic: Postgres sequence problem after DB restore - Help please
Replies: 12
Views: 1905

Wild_Pointer Thanks , I'll probably stick with the 3rd option for now. The introduction of TZSequence in versions after 6.1.5, however, implies a major overhaul of my code - something I just do not have the time for now I have never used TZSequence yet Sorry if this is a stupid question, but how do...
by gmb
08.11.2010, 20:54
Forum: 6.1.5
Topic: Postgres sequence problem after DB restore - Help please
Replies: 12
Views: 1905

1) update zeos components. (that would be the right thing to do). We are now using zeos 7 in our system without problems. As you say this will be the most "correct" way of solving the problem and probably something I'll have to take a look at in the long run. The introduction of TZSequenc...
by gmb
08.11.2010, 13:10
Forum: 6.1.5
Topic: Postgres sequence problem after DB restore - Help please
Replies: 12
Views: 1905

THanks for the replies. It loses the schema Hi Wild_Pointer, what you are saying here sounds exactly like my problem. Strange that is only occurring now. Maybe related to changes in pg_dump/pg_restore? Will changing the ZConnection.Protocol have any impact? Currently I'm using postgresql-7.3 (for no...
by gmb
05.11.2010, 15:20
Forum: 6.1.5
Topic: Postgres sequence problem after DB restore - Help please
Replies: 12
Views: 1905

Postgres sequence problem after DB restore - Help please

Hi all, Using Delphi6 & Postgres with zeos 6.1.5 - and have not had any problems like this before. My app is very dependant of schemas in the DB and also use serials columns for PK's: CREATE TABLE sch1.tab1( tabid SERIAL PRIMARY KEY, tabdesc TEXT ); which implies: CREATE SEQUENCE sch1.tab1_tabid...
by gmb
13.10.2009, 21:06
Forum: 6.1.5
Topic: Postgres : PGCLIENTENCODING
Replies: 2
Views: 677

Seems all that was necessary was a restart of the server :(
...wish I hadn't spend the whole day on this
by gmb
13.10.2009, 19:19
Forum: 6.1.5
Topic: Postgres : PGCLIENTENCODING
Replies: 2
Views: 677

Postgres : PGCLIENTENCODING

Hi all I'm getting the following message when trying to connect to Postgres server: [quote]SQL Error: invalid encoding name in PGCLIENTENCODING: WIN1252[/quote] Delphi 6 application with Zeos 6.1.5 on Windows 7 (64x), PostgreSQL 8.3 I tried re-installing PG using different encoding, but had no luck....
by gmb
16.07.2008, 15:12
Forum: 6.5.1 (alpha) - 6.6.x (beta)
Topic: Postgres CreateBlobStream Issue
Replies: 2
Views: 577

No worries - solved the problem by using a different protocol. After tracing the source code in both versions and comparing the different units I came to the conclusion: In unit ZPlainPostgreSqlDriver.pas: function TZPostgreSQL7PlainDriver.DecodeBYTEA(value: string): string; begin result:=va...
by gmb
16.07.2008, 10:06
Forum: 6.5.1 (alpha) - 6.6.x (beta)
Topic: Postgres CreateBlobStream Issue
Replies: 2
Views: 577

After doing some research I see it may have something to do with null-character (#0) and binary strings. Using v 6.1.5 components, the same delphi-code (as displayed above) generates the following SQL: INSERT INTO email.mailmaster (mail_id,att_file,att_name) VALUES (13,'BMæ\134000\134000\134000\1......
by gmb
15.07.2008, 16:32
Forum: 6.5.1 (alpha) - 6.6.x (beta)
Topic: Postgres CreateBlobStream Issue
Replies: 2
Views: 577

Postgres CreateBlobStream Issue

Hi there, Recently upgraded from v 6.1.5 to 6.6.2 (mainly for the fixes of memory problems) and I'm generally happy. But now walked into an issue with BLOBs; We use Delphi 6 with Postgres 8 with code that looks like this: Stream2 := TMemoryStream.Create; Stream2.LoadFromFile(sFile); ZTable1....

Go to advanced search