Error acessing mysql database with ZeosDB

Forum related to all 5.x versions of ZeosLib's DBOs

Moderators: gto, cipto_kh, EgonHugeist

Junior Thurler
Fresh Boarder
Fresh Boarder
Posts: 5
Joined: 29.03.2007, 15:34

Error acessing mysql database with ZeosDB

Postby Junior Thurler » 11.04.2007, 20:35

I'm using ZeosDB on D6, and when I try to connect with a TZMySqlDatabase component to my database, I receive the following message:

"Client does not support authentication protocol requested by the server; consider upgrading MySql client".

I'm using MySql Server 5.0 and ZeosDB 5

What could be this problem ?

[]s

JR

User avatar
mdaems
Zeos Project Manager
Zeos Project Manager
Posts: 2766
Joined: 20.09.2005, 15:28
Location: Brussels, Belgium
Contact:

Postby mdaems » 12.04.2007, 13:31

Problem is that you're using a protocol/dll which does not support the new authentication protocol used by mysql.
2 possible solutions (except for upgrading zeoslib, which has mysql5 support):
- Start the mysql server using 'old-passwords'. Read mysql docs about it. I don't think your dba will like it.
- Try to use a mysql 4.1 dll instead of the one you use now. This can give compatibility problems (dll interface may have changed). You just have to test it.

Mark

Junior Thurler
Fresh Boarder
Fresh Boarder
Posts: 5
Joined: 29.03.2007, 15:34

Postby Junior Thurler » 12.04.2007, 20:36

How can I upgrade my version of zeoslib since the name of components of the older version had changed ? There is a program to do that ?

JR

User avatar
mdaems
Zeos Project Manager
Zeos Project Manager
Posts: 2766
Joined: 20.09.2005, 15:28
Location: Brussels, Belgium
Contact:

Postby mdaems » 13.04.2007, 09:35

Not officially, I'm sure about that. Some people have given a description of how they did it, however. You'll have to search a little on the forum for that. (unless somebody else can point you right there, of course)

Mark


Return to “5.x Versions”

Who is online

Users browsing this forum: No registered users and 1 guest