ADO+MSSQL2K+NamedPipes

Forum related to ADO

Moderators: gto, cipto_kh, EgonHugeist

DestinyR
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: 10.03.2010, 16:59

ADO+MSSQL2K+NamedPipes

Postby DestinyR » 09.04.2010, 14:24

Hello!

I use MSSQL 2000 Developer Edition and wish to connect from network to my PC.
I want use named pipes, but I can't understand, how to implement this with ZConnection?

Thank for help and ideas!

P.S. I can't use Microsoft OLE DB Provider for ODBC drivers because it can't work correctly with DateTime format in mssql databases. It need be realized with SQL Native Client or Microsoft OLE DB Provider for SQL Server/

P.P.S. I can create user DSN connection with named pipes, but can't understand how to use it DSN in ZConnection/

DestinyR
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: 10.03.2010, 16:59

Postby DestinyR » 09.04.2010, 16:30

Next solution:
1) Create DSN in ODBC datasource administrator with change client properties on named pipes.
2) Create ZConnection string through "Microsoft OLE DB Provider for ODBC Drivers"
3) Change "Provider=MSDASQL.1" in ZConnection by "Provider=SQLOLEDB.1"

Enjoy!

bravecobra
Junior Boarder
Junior Boarder
Posts: 29
Joined: 31.10.2005, 00:09
Location: Antwerp
Contact:

Postby bravecobra » 10.04.2010, 18:50

What's holding you back from using TCP/IP instead of named pipes? That should make life a lot easier.
Brave Cobra
bravecobra.com

DestinyR
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: 10.03.2010, 16:59

Postby DestinyR » 12.04.2010, 07:38

As far as I know MSSQL2K Developer Edition don't implement TCP/IP realization.
And I have installed MSSQL2k5 as main server and MSSQL2kDE as secondary service with instance name sql2000. Any attempts to remote connect to secondary instance by TCP/IP fails.

bravecobra
Junior Boarder
Junior Boarder
Posts: 29
Joined: 31.10.2005, 00:09
Location: Antwerp
Contact:

Postby bravecobra » 16.04.2010, 02:52

TCPIP connections are not enabled by default if I remember correctly. You can enable it with the "SQL Server Network Utility" which should be be in your menu.
Here's a screenshot of my SQL2K with TCP/IP connections enabled. It too is a SQL 2k Dev Edition
You do not have the required permissions to view the files attached to this post.
Brave Cobra

bravecobra.com


Return to “ADO”

Who is online

Users browsing this forum: No registered users and 1 guest