Embedded FB2.5 errors

Forum related to Firebird

Moderators: gto, cipto_kh, EgonHugeist

Fresh Boarder
Fresh Boarder
Posts: 12
Joined: 26.10.2010, 21:04

Embedded FB2.5 errors

Postby vannus » 25.08.2011, 19:20

Anyone managed to get Zeos to work with embedded firebird 2.5?

From the IDE I'll get
"SQL Error: unavailable database. Error code -904. Unsuccessful execution caused by unavailable resource"

and from runtime I get
Access violation at 00000000

localhost is empty, tried database with relative and absolute paths to fdb file. Database is on local drive.

It works fine when using FB SuperServer, but not when using FB embedded :(

I've tried Zeos 6.6.6-stable 7.0.0-alpha and preview-7.0.1-alpha none of which have firebird-2.5 as an available protocol. I'm trying firebird-2.1 and firebirdd-2.1 protocols.

Delphi 7 Pro.

- V

Zeos Dev Team *
Zeos Dev Team *
Posts: 385
Joined: 04.06.2008, 19:50

Postby seawolf » 25.08.2011, 22:03

Lastest svn snapshot has support this firebird release.
Anyway it looks like you don't have set the path correctly or
the db is not located where it should be

Return to “Firebird”

Who is online

Users browsing this forum: No registered users and 1 guest