Delphi 2010 + Zeos + PostgreSQL

Forum related to PostgreSQL

Moderators: gto, cipto_kh, EgonHugeist, olehs

rblsystem
Fresh Boarder
Fresh Boarder
Posts: 7
Joined: 26.12.2013, 16:50

Delphi 2010 + Zeos + PostgreSQL

Postby rblsystem » 25.01.2018, 20:22

Hello guys.

I use version 7.2.0-alpha of the library for Delphi 2010.

I connect to the Postgree database hosted on AWS. The connection protocol is postgresql-9 configured in the ZConnnection component in the Protocol property.

Recently, AWS informed us that in February, they will change the version of PostGree to the versions:

PostgreSQL 9.3.x instances to PostgreSQL 9.3.20,
PostgreSQL 9.4.x instances to PostgreSQL 9.4.15,
PostgreSQL 9.5.x instances to PostgreSQL 9.5.10,
PostgreSQL 9.6.x instances to PostgreSQL 9.6.6 or higher.

I have the option of letting AWS change automatically by the due date or change before that.

My question is about the component. I would like to know if I need to install a new version of the Zeos library in Delphi 2010 for a version larger than 7.2.0-alpha or if I can keep this version ?!

If I keep version 7.2.0-alpha, will I have a problem when I change the PostGree version there in AWS?

What is the recommendation of you for my case?

Thank you,

Rogerio

marsupilami
Gold Boarder
Gold Boarder
Posts: 671
Joined: 17.01.2011, 14:17

Re: Delphi 2010 + Zeos + PostgreSQL

Postby marsupilami » 26.01.2018, 09:04

Hello Rogerio,

you don't need to change anything from a Zeos point of view. Zeos should work nicely with all those versions.

With best regards,

Jan


Return to “PostgreSQL”

Who is online

Users browsing this forum: No registered users and 1 guest