MSSQL Stored Procedure - expects parameter xxx not supplied

Forum related to MS SQL Server

Moderators: gto, cipto_kh, EgonHugeist

taguah
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 04.07.2009, 05:58

MSSQL Stored Procedure - expects parameter xxx not supplied

Postby taguah » 04.07.2009, 10:45

Delphi 5 Pro + Zeos 6.6.3, Zeos 6.6.5 + MSSQL 2005.

I recently updated to zeos 6.6.3 to 6.6.5. It has a problem on executing stored procedure using mssql dblib protocol. But only happen on procedure which have output params.

It works on the first execution, but show err messages on the next execution as

"Procedure of Function 'procedure_name' expects parameter '@xxxx', which was not supplied".

It does not happen to connection protocol using ADO, or even in firebird 2.1. It also does not happen if I create the zstoredproc run time.

I tried to search in available topics. Is this only happen to mssql protocol?

taguah
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 04.07.2009, 05:58

Postby taguah » 04.07.2009, 10:47

It also does not happen if I create the zstoredproc run time for each execution.

User avatar
mdaems
Zeos Project Manager
Zeos Project Manager
Posts: 2766
Joined: 20.09.2005, 15:28
Location: Brussels, Belgium
Contact:

Postby mdaems » 08.07.2009, 22:19

taguah,

I'm afraid you'l have to debug. dblib users become very rare.

Just have a look at the call stack when te error occurs and I think you can easily decide where to put some debug points to see what happens exactly.

Mark
Image


Return to “MS SQL Server”

Who is online

Users browsing this forum: No registered users and 1 guest