Error zeos lib 6.65 + lazarus 0.9.28 + opensuse 11

Forum related to the ZDBC API-Layer

Moderators: gto, cipto_kh, EgonHugeist

harwin
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: 21.12.2009, 23:01

Error zeos lib 6.65 + lazarus 0.9.28 + opensuse 11

Postby harwin » 21.12.2009, 23:14

when I trying connect to mssql server from linux using lazarus 0.9.28 + zeos lib 6.65 on opensuse, get the next error:

None of the dynamic libraries can be found: ntwdblib.dll

help me please.
You do not have the required permissions to view the files attached to this post.

User avatar
mdaems
Zeos Project Manager
Zeos Project Manager
Posts: 2766
Joined: 20.09.2005, 15:28
Location: Brussels, Belgium
Contact:

Postby mdaems » 23.12.2009, 00:01

Does your opensuse installation provide drivers for mssql? I suppose they are not called ntwdblib.dll. If a linux variant with the same interface as this dll exists for linux we could add it's name to the list of names that should be checked on Linux.
I'm afraid however the solution isn't that easy.

Zeoslib usually uses the c API interfaces provided by the database. Usually it loads one or more dll's and calls the functions inside to communicate with the server. So there's no direct communication with the port the db server is listening on. (however, somebody could write this kind of 'plaindriver class' and plug it into the zeoslib framework without too much trouble) For mysql, postgres, firebird and sqlite there are linux version of the API dll's available. I never heard about these for ADO, ODBC, mssql. Not sure if M$ has problems with Linux. Looks like that...

Mark
Image


Return to “ZDBC (ZEOS Database Connectivity)”

Who is online

Users browsing this forum: No registered users and 1 guest