[solved] error, last svn of today. ZAbstractRODataset.pas

The alpha/beta tester's forum for ZeosLib 7.0.x series

Report problems concerning our Delphi 2009+ version and new Zeoslib 7.0 features here.

This is a forum that will be removed once the 7.X version goes into stable!!

Moderators: gto, EgonHugeist, olehs

wylton
Senior Boarder
Senior Boarder
Posts: 58
Joined: 14.07.2011, 20:56

[solved] error, last svn of today. ZAbstractRODataset.pas

Postby wylton » 23.08.2012, 10:39

D:\lazarus\components\zeos\src\component\ZAbstractRODataset.pas(3487,48) Error: Expected another 2 array elements


use Lazarus 1.0rc2, fpc 2.6.0, win7 x32.
Last edited by wylton on 31.08.2012, 11:12, edited 1 time in total.

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1739
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 23.08.2012, 10:40

wylton,

Some code to reproduce the issue? A hint what you are doing?

Oh i had a look now. It might be possible that with you FPC version an upgrade was none. Maybe somebody can check this?
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image

wylton
Senior Boarder
Senior Boarder
Posts: 58
Joined: 14.07.2011, 20:56

Postby wylton » 23.08.2012, 11:01

I just download Lazarus rc2 and zeos today, no other thing installed.

olehs
Zeos Dev Team
Zeos Dev Team
Posts: 118
Joined: 09.11.2009, 21:05

Postby olehs » 23.08.2012, 23:38

wylton,

maybe you should try http://wiki.freepascal.org/Zeos_tutorial (at the end of the page)
Oleg

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1739
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 24.08.2012, 10:18

olehs,

i checket the tutorial. He is outdated the the proposed fixes are wrong except there is a little ifdef FPC25_UP left in the sources.

That makes me a little bit wondering now, becouse one of the FPC-core did fix the discribed issues of the tutorial. But these issues are still remaining with the deprecated 6.6 components..

I'll ask for help.
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image

wylton
Senior Boarder
Senior Boarder
Posts: 58
Joined: 14.07.2011, 20:56

Postby wylton » 27.08.2012, 11:55

i do like this :
{$IFDEF FPC}
const
BaseFieldTypes: array[TFieldType] of TFieldType = (
ftUnknown, ftString, ftInteger, ftInteger, ftInteger, ftBoolean, ftFloat,
ftFloat, ftBCD, ftDateTime, ftDateTime, ftDateTime, ftBytes, ftVarBytes,
ftInteger, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftUnknown,
ftString, ftString, ftLargeInt, ftADT, ftArray, ftReference, ftDataSet,
ftBlob, ftBlob, ftVariant, ftInterface, ftInterface, ftString, ftTimeStamp, ftFMTBcd,
//{$IFDEF FPC2_1UP}, ===========modification
ftString, ftBlob); //{$ENDIF});

it can compile....but i don't know if do this, Whether it will cause unsafe?
Last edited by wylton on 28.08.2012, 08:47, edited 1 time in total.

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1739
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 28.08.2012, 08:06

wylton,

thank you... I Can't find this lines in Zeos7, wylton. Checkout with this URL http://svn.code.sf.net/p/zeoslib/code-0 ... es/testing
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image

wylton
Senior Boarder
Senior Boarder
Posts: 58
Joined: 14.07.2011, 20:56

Postby wylton » 28.08.2012, 08:46

D:\0828\src\component\ZAbstractRODataset.pas(111,17) Warning: An inherited method is hidden by "constructor TZDataLink.Create(TZAbstractRODataset);"
D:\0828\src\component\ZAbstractRODataset.pas(294,15) Note: Virtual method "TZAbstractRODataset.SetFieldData(TField,Pointer,Boolean);" has a lower visibility (protected) than parent class TDataSet (public)
D:\0828\src\component\ZAbstractRODataset.pas(296,15) Note: Virtual method "TZAbstractRODataset.SetFieldData(TField,Pointer);" has a lower visibility (protected) than parent class TDataSet (public)
D:\0828\src\component\ZDatasetUtils.pas(792,42) Hint: Local variable "Temp" does not seem to be initialized
D:\0828\src\component\ZDatasetUtils.pas(854,54) Warning: Local variable "WValue2" does not seem to be initialized
D:\0828\src\component\ZDatasetUtils.pas(1085,22) Error: identifier idents no member "GetClientCodePage"
D:\0828\src\component\ZDatasetUtils.pas(1085,59) Error: Identifier not found "ceAnsi"
D:\0828\src\component\ZDatasetUtils.pas(1114,85) Error: Identifier not found "FLOAT_COMPARE_PRECISION_SINGLE"
D:\0828\src\component\ZDatasetUtils.pas(1639) Fatal: There were 3 errors compiling module, stopping

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1739
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 30.08.2012, 02:06

wylton,

oh i think this times you need to recompile Lazarus completely. Here i can see you are mixing old and new files. So remove the ZComponent package, compile Lazarus, add the Package and compile Lazarus.

Tomorrow i'll download L1.0RC2 to verify the issue.
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image

wylton
Senior Boarder
Senior Boarder
Posts: 58
Joined: 14.07.2011, 20:56

Postby wylton » 30.08.2012, 18:20

i download today lazarus 1.0.
the same error.

D:\zeos\src\component\ZAbstractRODataset.pas(3487,48) Error: Expected another 2 array elements

with this URL http://svn.code.sf.net/p/zeoslib/code-0 ... es/testing

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1739
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 31.08.2012, 00:19

wylton,

this i can not confirm. I downloaded Lazarus1.0RC2+FPC2.6 and everything is fine if you compile only the files from http://svn.code.sf.net/p/zeoslib/code-0 ... es/testing.

Be sure you've removed all other old files.
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image

wylton
Senior Boarder
Senior Boarder
Posts: 58
Joined: 14.07.2011, 20:56

Postby wylton » 31.08.2012, 08:34

are you sure??


i trid again, same error....
i with windows 7 x32, with spainish local, and with chinese unicode..

wylton
Senior Boarder
Senior Boarder
Posts: 58
Joined: 14.07.2011, 20:56

Postby wylton » 31.08.2012, 08:36

with lazarus 1.0, all new, don't have any old files.

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1739
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 31.08.2012, 10:09

wylton,

I'm sure. See attachement... No problem to use Zeos7 from SVN. So ther must be an issue on you computer.
You do not have the required permissions to view the files attached to this post.
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image

wylton
Senior Boarder
Senior Boarder
Posts: 58
Joined: 14.07.2011, 20:56

Postby wylton » 31.08.2012, 11:11

thanks.

I delete C:\Users\sa\AppData\Local\lazarus, recompile http://svn.code.sf.net/p/zeoslib/code-0 ... es/testing
it work...thank you..

but with svn://zeos.firmos.at/zeos/trunk can't.


Return to “ZeosLib 7.0 Beta Forum”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest