Bookmark was not found in XE3 remote Mysql connection

The alpha/beta tester's forum for ZeosLib 7.0.x series

Report problems concerning our Delphi 2009+ version and new Zeoslib 7.0 features here.

This is a forum that will be removed once the 7.X version goes into stable!!

Moderators: gto, EgonHugeist, olehs

Fresh Boarder
Fresh Boarder
Posts: 1
Joined: 26.10.2012, 17:58

Bookmark was not found in XE3 remote Mysql connection

Postby TryMan » 26.10.2012, 18:10

i was used remote connection to my Mysql database v4.1. when i post record in ZAbstractRODataset.pas program catch an exception "Bookmark was not found"
i was read this , but my procedure GetBookmarkData(Buffer: PChar; Data: Pointer) is override not overload; virtual;

User avatar
Zeos Dev Team
Zeos Dev Team
Posts: 1735
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 27.10.2012, 12:00


You are right too. AFAIK there are two overoaded procedures for X3 availabe for Get/SetBookmarkData.

One DEPRECATED with the pointer we had and which won't be callled from X3 any more.
The second overload was with the TBookmarkData and this one will be called now.

Just have a look to the Embarcadero docs.

IMHO that patch should fix this issue. Remaining is the confirmation if it does. Did you download Zeos from SVN or the Beta-relaese 'em selves?
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude!


Return to “ZeosLib 7.0 Beta Forum”

Who is online

Users browsing this forum: No registered users and 1 guest