Zeoslib and clientdataset

In this forum all bug reports concerning the 6.x branch will be gahtered. You have the possibility to track the bug fix process.

Moderators: EgonHugeist, mdaems

robsonselzelin
Fresh Boarder
Fresh Boarder
Posts: 8
Joined: 09.07.2006, 20:56
Contact:

Zeoslib and clientdataset

Postby robsonselzelin » 14.07.2006, 12:08

Hi Zeos development team.

There is an implementation of master/detail relationship between clientdatasets that I can't get with Zeoslib. Read the following Borland article, you won't take more than half hour to read and implement it:

http://bdn1.borland.com/article/0,1410,29825,00.html

Now, try to implement it with any Zeos dataset. You won't get the detail records. They'll appear but with null values. I realy like Zeoslib but I can't use it if doesn't work with this Delphi resource.

I got this Zeoslib behavior with MySQL. Thanx.

raduborcan
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 18.10.2007, 20:59

Postby raduborcan » 18.10.2007, 21:07

Hi there,

Unfortunatelly I noticed that problem in Oracle, MsSQl and Postgre and seems that it isn't solved from over a year.

Any chance?

Regards.

User avatar
mdaems
Zeos Project Manager
Zeos Project Manager
Posts: 2766
Joined: 20.09.2005, 15:28
Location: Brussels, Belgium
Contact:

Postby mdaems » 19.10.2007, 07:14

Hi,

Is this the problem of bugs
http://zeosbugs.firmos.at/view.php?id=43
and
http://zeosbugs.firmos.at/view.php?id=59 ?
In that case I'm afraid we need somebody with more knowledge of clientdataset behaviour. I had a look at the provided sample applications, but wasn't able to find where in the zeoslib query component bad data is retrieved. Probably there's something in standard TDataset behaviour that's used by the ClientDataset that we don't handle wel (or handle at all).
Is there somebody who know more about this? Please, step forward.

Mark

raduborcan
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 18.10.2007, 20:59

Postby raduborcan » 21.10.2007, 09:45

Hi all,

I think that is related only with
http://zeosbugs.firmos.at/view.php?id=43


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest