Crash after Post - what's happening?

In this forum we will discuss things relating the ZEOSLib 6.6.x stable versions

Moderators: gto, EgonHugeist

IbeDBob
Junior Boarder
Junior Boarder
Posts: 47
Joined: 27.05.2010, 21:04

Crash after Post - what's happening?

Postby IbeDBob » 21.03.2013, 14:29

Hi All,

New user to Zeos; I am using D5 with SQLite3 and I have to use 6.6 Stable as 7. has dropped D5 Package. I am also using the TNT Unicode components.

I am converting over from BDE to SQLite3 and the BDE app was running fine. Made all the changes needed and the app runs, but with all empty Tables.

Tried to enter a new Account to a table using Table.Insert and Table.Post and I get a crash with an error message "Bad logic or missing database"

Using the call stack I go back to the call before the error handling and there is an SQL statement "SELECT True,5,True"

No surprises it crashed but what do I need to do to get past this?

Fields data types are nothing fancy, Char, Integer and Boolean.

Thanks
Thanks

Dyslexic Bob

IbeDBob
Junior Boarder
Junior Boarder
Posts: 47
Joined: 27.05.2010, 21:04

Postby IbeDBob » 21.03.2013, 14:44

OK, the plot thickens.

I used a standard D5 Data Aware DBEdit and disable all the TNT stuff just in case. Same error. With only a single input field, this left all but one of the Fields empty for the Post.

Back tracking, the SQL text now shows...

"SELECT True,5,True,True,False"

...which looked familiar. They are the Default values for the Fields in the Table. There are only 5 fields with defaults and that's the pattern.

It appears that Zeos is not handling the Default values well.

Could that be it?

How to fix it?

Thanks
Thanks



Dyslexic Bob


Return to “6.6 - stable”

Who is online

Users browsing this forum: No registered users and 1 guest