ZeosLib 7.1 + XE4 + PostGreSql returns no data

The official tester's forum for ZeosLib 7.1. Ask for help, post proposals or solutions.
rudimar
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: 12.06.2012, 17:47

ZeosLib 7.1 + XE4 + PostGreSql returns no data

Postby rudimar » 05.06.2013, 20:45

Hi,

I'm using ZeoLib 7.1 + XE4 + PostGreSql returns no data,

returns table fields, but not the data, why is it?

and the table is not empty.

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1739
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 06.06.2013, 13:03

rudimar,

since XE3 Set/GetFieldData using a TValueBuffer. Now i had a look to Zeos.Inc. I'm affraid the one who made the XE4 modifikations did add {$UNDEF WITH_TVALUEBUFFER} to the {DELPHI18_UP} section. Can you comment it by {.$UNDEF WITH_TVALUEBUFFER}, recompile and check if the Data is available again?
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image

rudimar
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: 12.06.2012, 17:47

Postby rudimar » 06.06.2013, 18:03

Egon,

I check,

sorry, where exactly is this session? What Unit?

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1739
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 06.06.2013, 23:30

rudimar,

open file (Your Zeos directory)\src\zeos.inc

goto {$UNDEF WITH_TVALUEBUFFER} in Delphi18 section:

Code: Select all

{$IFDEF DELPHI18_UP}
  {$UNDEF WIDE_DATASET}                // TWideDataset and TDataSet are merged together: https://forums.embarcadero.com/thread.jspa?messageID=499588
  {$DEFINE WITH_TVALUEBUFFER}          // SetFieldData/GetFieldData and Parameters using TValueBuffer instead of Pointer
  {$DEFINE WITH_BOOKMARKDATA_TBOOKMARK}
  {$UNDEF WITH_WIDESTRINGS_GETFIELDNAMES} //GetFieldNames with TWideStrings has been removed
  {$UNDEF WITH_TVALUEBUFFER}
  {$DEFINE WITH_SYSUITLS_PREFIX}    //Need SysUtils. unit declaration for some functions like StrNew,StrAlloc
{$ENDIF}

and comment this line like this: {.$UNDEF WITH_TVALUEBUFFER}

Recompile, and check if it works..
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image

rudimar
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: 12.06.2012, 17:47

Postby rudimar » 07.06.2013, 03:06

Hi,

[dcc32 Error] ZAbstractRODataset.pas(440): E2037 Declaration of 'GetFieldData' differs from previous declaration

Code: Select all

function GetFieldData(Field: TField; Buffer: {$IFDEF WITH_TVALUEBUFFER}TValueBuffer{$ELSE}Pointer{$ENDIF}): Boolean; override;

function GetFieldData(Field: TField; Buffer: {$IFDEF WITH_TVALUEBUFFER}TValueBuffer{$ELSE}Pointer{$ENDIF};

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1739
Joined: 31.03.2011, 22:38

Postby EgonHugeist » 08.06.2013, 19:56

rudimar,

i've commited a "theoretical" patch: R2287 /testing7.1 (SVN)

see http://docwiki.embarcadero.com/Librarie ... tFieldData

Please update and report if it works now.
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image


Return to “ZeosLib 7.1 stable Forum”

Who is online

Users browsing this forum: No registered users and 1 guest