Problem with compiling BPL files to install component

The official tester's forum for ZeosLib 7.1. Ask for help, post proposals or solutions.
EnderX
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: 01.12.2016, 20:31

Problem with compiling BPL files to install component

Postby EnderX » 02.12.2016, 23:24

I am attempting to install Zeos 7.1.4 on a Windows 7 machine (64-bit), for use with Delphi 7. I am opening Delphi in 'Run as Administrator' before I am attempting to do any of this.

I am attempting to follow the instruction pdf that came packaged with the install zip file. In doing so, I am running into a problem that I am uncertain how to handle correctly.

In step 4 of the instructions, there is a list of .bpl files, which are to be compiled - ZCore, ZParseSql, ZPlain, ZDbc, and ZComponent. When attempting to compile these files, I can see the .bpl files being created (see their timestamps being updated, rather) in my system's BPL directory for the first four. I cannot see any sign that the ZComponent file is being created. When I attempt to move on to the next step, I get an error message, as shown below:
"The program can't start because ZComponent70.bpl is missing from your computer. Try reinstalling the program to fix this problem."

Please, what is it that I'm missing? I cannot figure out why that file, and only that file, is not compiling. I'm not finding any sign of it, not only in that directory, but anywhere on my system. Does ZComponent perhaps require some library file I'm missing? I wouldn't have thought so, but I cannot think of any other reason why it won't compile.

Thank you for your assistance.
-EnderX

marsupilami
Gold Boarder
Gold Boarder
Posts: 591
Joined: 17.01.2011, 14:17

Re: Problem with compiling BPL files to install component

Postby marsupilami » 03.12.2016, 10:05

Hello EnderX,

Delphi 7 handles a lot of things in a very old way. I suggest that you assign write permissions for your regular users group to the Delphi Installation Directory and all subdirectories. There is a check box for doing the recursion part usually. This helped me with Delphi 6 on Windows 7.

Also I suggest you use the current Zeos 7.2 branch from SVN, as I suggested in other threads.

I suggest you do the following:
  1. set the permissions as I said above. This should allow you to start Delphi without Administrator privileges.
  2. remove Zeos from your installed components list in Delphi and restart Delphi.
  3. find and remove all Z*.bpl files on your computer
  4. find and remove all Z*.dcu files on your computer
  5. recompile the Zeos packages. Check out for errors during compilation. Check if all the necessary dcu- and bpl-files show up in all the correct places.
  6. install the ZComponent package
  7. restart your Delphi to see if things worked out for you.
  8. don't forgert to modify your library search path in Delphi so your projects will compile correctly.
If you have any problems, let me know.

With best regards,

Jan


Return to “ZeosLib 7.1 stable Forum”

Who is online

Users browsing this forum: No registered users and 1 guest