Problem with delphi xe4 and zeos 7.0.4-stable

The stable tester's forum for ZeosLib 7.0.x series

Report problems concerning our Delphi 2009+ version and new Zeoslib 7.0 features here.
rmbenitez
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: 30.09.2009, 16:58

Problem with delphi xe4 and zeos 7.0.4-stable

Postby rmbenitez » 29.08.2013, 18:20

I have delphi xe4 enterprise and zeos 7.0.4-stable install,and i have two problems.

1) insert tzconnection component and put all parameters, insert tzquery component and link with tzconnection.
Connect with MYSQL database 5.1.11. The tzquery have a sql string SELECT to table with 634 records.

zbusca -> tzquery

zbusca.sql.text := 'SELECT * FROM localidades';
zbusca.open;
showmessage(inttostr(zbusca.recordcount)); ----------->>> Show 634,
zbusca.first;
showmessage(inttostr(zbusca.recno)); --------->>>> Show 2 ?????
showmesage(zbusca.fieldbyname('campo').text) --------->>>>> Show ' ' when the first record have 'prueba'
while not zbusca.eof do -------->>>>> At the first time show true

The component only return data from the propierties, but the object tzquery don't have data.


2) insert tzconnection component and put all paramters, in execute time i connect with the MYSQL database, but in design time, i have the follow errors

Access violation at address 50060cf4 en module rtl180.bpl. Read of address 00000010.
[50060CF4]{rtl180.bpl } System.@UStrClr (Line 22442, "System.pas" + 0) + $0
[165723D9]{ZPlain180.bpl} ZPlainLoader.TZNativeLibraryLoader.LoadNativeLibrary$qqrv (Line 237, "ZPlainLoader.pas" + 14) + $39
[16573610]{ZPlain180.bpl} ZPlainDriver.TZAbstractPlainDriver.Initialize$qqrx20System.UnicodeString (Line 436, "ZPlainDriver.pas" + 9) + $8
[2597437C]{ZComponent180.bpl} ZDbcMySql.TZMySQLDriver.GetPlainDriver$qqrxp10Zurl.TZURLxo (Line 245, "ZDbcMySql.pas" + 10) + $1B
[2575CCF6]{ZDbc180.bpl } ZDbcConnection.TZAbstractConnection.$bctr$qqrxp10Zurl.TZURL (Line 688, "ZDbcConnection.pas" + 7) + $11
[25974211]{ZComponent180.bpl} ZDbcMySql.TZMySQLDriver.Connect$qqrxp10Zurl.TZURL (Line 184, "ZDbcMySql.pas" + 1) + $A
[2575C39F]{ZDbc180.bpl } ZDbcConnection.TZAbstractDriver.Connect$qqrx20System.UnicodeStringp23System.Classes.TStrings (Line 364, "ZDbcConnection.pas" + 3) + $B
[257442DE]{ZDbc180.bpl } ZDbcIntfs.TZDriverManager.GetConnectionWithParams$qqrx20System.UnicodeStringp23System.Classes.TStrings (Line 1066, "ZDbcIntfs.pas" + 4) + $F
[25A20BEA]{ZComponent180.bpl} ZAbstractConnection.TZAbstractConnection.Connect$qqrv (Line 848, "ZAbstractConnection.pas" + 34) + $2B
[25A20370]{ZComponent180.bpl} ZAbstractConnection.TZAbstractConnection.SetConnected$qqro (Line 510, "ZAbstractConnection.pas" + 8) + $5
[501252CA]{rtl180.bpl } System.TypInfo.SetOrdProp (Line 2595, "System.TypInfo.pas" + 33) + $0
[2111D83A]{designide180.bpl} DesignEditors.TPropertyEditor.SetOrdValue (Line 839, "DesignEditors.pas" + 2) + $E
[21162DF7]{designide180.bpl} VCLEditors.TBooleanProperty.MouseUp (Line 1864, "VCLEditors.pas" + 5) + $10
[212B1359]{vclide180.bpl} PropBox.TCustomPropListBox.ItemMouseUp (Line 1631, "PropBox.pas" + 17) + $1B
[212B154F]{vclide180.bpl} PropBox.TCustomPropListBox.MouseUp (Line 1696, "PropBox.pas" + 1) + $D
[50453488]{vcl180.bpl } Vcl.Controls.TControl.DoMouseUp (Line 7468, "Vcl.Controls.pas" + 2) + $28
[50453504]{vcl180.bpl } Vcl.Controls.TControl.WMLButtonUp (Line 7481, "Vcl.Controls.pas" + 9) + $6
[212B6CDC]{vclide180.bpl} IDEInspListBox.TInspListBox.WMLButtonUp (Line 1632, "IDEInspListBox.pas" + 3) + $4
[50452AF9]{vcl180.bpl } Vcl.Controls.TControl.WndProc (Line 7224, "Vcl.Controls.pas" + 91) + $6
[50456DEB]{vcl180.bpl } Vcl.Controls.TWinControl.IsControlMouseMsg (Line 9807, "Vcl.Controls.pas" + 1) + $9
[504575B5]{vcl180.bpl } Vcl.Controls.TWinControl.WndProc (Line 10039, "Vcl.Controls.pas" + 153) + $6
[5047AE29]{vcl180.bpl } Vcl.StdCtrls.TCustomListBox.WndProc (Line 7108, "Vcl.StdCtrls.pas" + 55) + $5
[50456BF8]{vcl180.bpl } Vcl.Controls.TWinControl.MainWndProc (Line 9751, "Vcl.Controls.pas" + 3) + $6
[50170090]{rtl180.bpl } System.Classes.StdWndProc (Line 16860, "System.Classes.pas" + 8) + $0
[50580E87]{vcl180.bpl } Vcl.Forms.TApplication.ProcessMessage (Line 10288, "Vcl.Forms.pas" + 23) + $1
[50580ECA]{vcl180.bpl } Vcl.Forms.TApplication.HandleMessage (Line 10318, "Vcl.Forms.pas" + 1) + $4
[50581205]{vcl180.bpl } Vcl.Forms.TApplication.Run (Line 10456, "Vcl.Forms.pas" + 26) + $3

IN SUMMARY, the zeos is installed, but don't work.
Can anyone help me.

Thanks

User avatar
EgonHugeist
Zeos Dev Team
Zeos Dev Team
Posts: 1701
Joined: 31.03.2011, 22:38

Re: Problem with delphi xe4 and zeos 7.0.4-stable

Postby EgonHugeist » 29.08.2013, 21:37

rmbenitez

Switch to SVN \trunk or \testing-7.1. It looks like we've loved the remaining issues for XE4.
King regards, Michael

You want to help? viewtopic.php?f=4&t=3671
You found a (possible) bug? Use the new bugtracker dude! http://sourceforge.net/p/zeoslib/tickets/

Image


Return to “ZeosLib 7.0 Stable Forum”

Who is online

Users browsing this forum: No registered users and 1 guest