Insert problem with SQLite and D2010

The stable tester's forum for ZeosLib 7.0.x series

Report problems concerning our Delphi 2009+ version and new Zeoslib 7.0 features here.
mnemonic_br
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 13.09.2013, 10:45

Insert problem with SQLite and D2010

Postby mnemonic_br » 13.09.2013, 11:02

Hi people,
I am new here but have been using ZL for sereval years, mainly with PostgreSQL. Right now I start a new application which requiries using SQLite. I downloaded the lastest sqlite3.dll and put my comps on the project. Everything seems to work fine but the insert into.

The insert statement will not work, getting me a wierd problem on the table as it results of repeating the same data for all the fields! Select is working fine, delete not tested yet.

So, if I do: insert into mytable (id, name, addr) values (:id, :name:, :addr) and use a qry.ParamByName('name').AsString (or .Value) and set the addr parameter, none of that info will be saved, strangely the ID column value will replace all the fields.

Is there another right way to use ZL with Sqlite? I really need solve this asap.

Thank you everyone.

marsupilami
Gold Boarder
Gold Boarder
Posts: 591
Joined: 17.01.2011, 14:17

Re: Insert problem with SQLite and D2010

Postby marsupilami » 14.09.2013, 08:04

Hello mnemonic_br,

which version of Zeos and Delphi or FPC do you use?
Best regards,

Jan


Return to “ZeosLib 7.0 Stable Forum”

Who is online

Users browsing this forum: No registered users and 1 guest