Disable MYSQL secure_auth

The stable tester's forum for ZeosLib 7.0.x series

Report problems concerning our Delphi 2009+ version and new Zeoslib 7.0 features here.
fjesteban
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: 30.10.2013, 17:22

Disable MYSQL secure_auth

Postby fjesteban » 30.10.2013, 17:36

Hello,

I'm trying to connect to a remote MySQL server and i get this exception error:
Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)
I'm tried to disable the "secure_auth" option by adding the string "MYSQL_SECURE_AUTH=false" to the TZConnection properties, but i get the same error.
I'm using ZeosLib 7.0.4 and Delphi 7. The server has MySQL 5.0.95

Thanks in advance

Return to “ZeosLib 7.0 Stable Forum”

Who is online

Users browsing this forum: No registered users and 1 guest