[Solved] Zeos 7.2.1 rc Lazarus 1.6.4 and Firebird 3.0 failed

The forum for ZeosLib 7.2 Report problems. Ask for help, post proposals for the new version and Zeoslib 7.2 features here. This is a forum that will be edited once the 7.2.x version goes into RC/stable!!

My personal intention for 7.2 is to speed up the internals as optimal a possible for all IDE's. Hope you can help?! Have fun with testing 7.2
luckylynx
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 29.01.2017, 09:51

[Solved] Zeos 7.2.1 rc Lazarus 1.6.4 and Firebird 3.0 failed

Postby luckylynx » 31.05.2017, 09:38

Hi,
my program, developed with Lazarus 1.6 , Zeos 7.2.1 rc and Firebird 3.0 works fine.
An update to Lazarus 1.6.4 compiles but the program did not work anymore.
A deeper look into it shows, that Zeos cause the problem.
A simple connection with Zconnection, ZQuery and Datasource with the SQL syntax 'Select max(orderno) as orderno from orders'
failed with the message 'Zquery: Field not found - IDNo'. IDNo is the first field in the table.
A connection with the Lazarus SQLdb IBconnection in Lazarus 1.6.4 works fine, so Lazarus seems not the problem.
Any ideas ?
In the Lazarus forum I go no reply, maybe someone here could help.
Thanks in advance.

marsupilami
Gold Boarder
Gold Boarder
Posts: 673
Joined: 17.01.2011, 14:17

Re: Zeos 7.2.1 rc Lazarus 1.6.4 and Firebird 3.0 failed

Postby marsupilami » 31.05.2017, 14:54

Hello luckylynx,

in the german Lazarus Forums there is a thread saying that Lazarus 1.6.2 and Zeos let you use persistent field components whereas you get errors when you try to do that with Lazarus 1.6.4. This would be correct beaviour.

Do you use persistent field components? Could you try to create a small sample project?

With best regards,

Jan

luckylynx
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 29.01.2017, 09:51

Re: Zeos 7.2.1 rc Lazarus 1.6.4 and Firebird 3.0 failed

Postby luckylynx » 31.05.2017, 18:03

Hi marsupilami,
I read your reply and the German forum about persistent fields , removed them in my example program and voila, the error is gone.
Unfortunately I have to change my program now which will take weeks.
Thank you for your quick and perfect hint. Solved.
Best regards


Return to “ZeosLib 7.2 Forum”

Who is online

Users browsing this forum: No registered users and 1 guest