Server gone away after a select query

Forum related to version 6.5.1 (alpha) and 6.6.x (beta) of ZeosLib's DBOs

Moderators: gto, cipto_kh, EgonHugeist

zippo
Silver Boarder
Silver Boarder
Posts: 322
Joined: 12.10.2005, 18:01
Location: Slovenia

Server gone away after a select query

Postby zippo » 13.06.2009, 17:50

Hi!

I have a very strange problem. When executing a select query (that is correct, because it works in the MySQL Browser) instead of the result i get an error "MySql has gone away". Must say that the server works without problems.

- It happens only on one database.
- The server doesn't crash.

I noticed the big number at system status variable "Aborted_clients", but I can't explain what could be possibly wrong. I tried:

- To connect as a different user.
- To connect from a different client

Please, I need urgent help, because in the testing phase this never happened (onn the same server) and now that we use the application "live" this is a critical issue!

BDS2006,
MySQL 5.0.51 on Linux
Zeos 6.5.x

User avatar
mdaems
Zeos Project Manager
Zeos Project Manager
Posts: 2766
Joined: 20.09.2005, 15:28
Location: Brussels, Belgium
Contact:

Postby mdaems » 16.06.2009, 13:54

THis usually means some minor incompatibility between client dll and mysql server. Are ou using the 5.0.51 dll?
I have no explanation what the number of aborted clients concerns. It may very well be related.

Mark
Image

zippo
Silver Boarder
Silver Boarder
Posts: 322
Joined: 12.10.2005, 18:01
Location: Slovenia

Postby zippo » 16.06.2009, 14:07

Found the bug.. It was a communication problem. Our client got a very unstable line and strange things happened.

Thanx!

zippo
Silver Boarder
Silver Boarder
Posts: 322
Joined: 12.10.2005, 18:01
Location: Slovenia

Postby zippo » 22.06.2009, 16:17

Jost for curiosity - how you know what version of the DLL ar you using..? I use the Zeos bundled mysql5.dll

User avatar
mdaems
Zeos Project Manager
Zeos Project Manager
Posts: 2766
Joined: 20.09.2005, 15:28
Location: Brussels, Belgium
Contact:

Postby mdaems » 23.06.2009, 23:40

Hi zippo,

At the moment we don't bundle the dll's anymore in the official releases. the general advise is to use the official dll's for the server release you're using.

To know what version you're using you can always use the ZConnection.ClientVersionStr property.

Mark
Image


Return to “6.5.1 (alpha) - 6.6.x (beta)”

Who is online

Users browsing this forum: No registered users and 1 guest