connecting to postgresql - pwd authent. failed

Forum related to version 6.5.1 (alpha) and 6.6.x (beta) of ZeosLib's DBOs

Moderators: gto, cipto_kh, EgonHugeist

bitmapbrother
Fresh Boarder
Fresh Boarder
Posts: 8
Joined: 24.11.2005, 09:34
Contact:

connecting to postgresql - pwd authent. failed

Postby bitmapbrother » 25.11.2005, 13:15

Hi I got another problem :oops:
When I try to connect to postgres server I will get this message:

SQL Error: FATAL: password authentication failed for user "bitmapbrother"

... but ZConnection->User is set to "janitor" which is working account - "bitmapbrother" is my windows login/username ... I am getting crazy about that especially coz I am able to connect to this server without problems using native libpq.dll. Thx for any ideas.

orlando
Fresh Boarder
Fresh Boarder
Posts: 10
Joined: 20.11.2005, 01:20
Location: São Paulo / SP
Contact:

Postby orlando » 01.12.2005, 12:01

Hi,

I was passing for this error to a passed time, discovered that I was omitting the connection door then it I was connecting door 5432 and my area for test was in the 5433 where the user and the password were different. E an idea, therefore is this does not have problems in connecting to a base PostGre-SQL using TZConnection

ex:
TZConnection1.HostName:= ip;
TZConnection1.protocol :=PostGresql-7.4;
TZConnection1.database :=NameDatabase;
TzConnection1.user :=myuser;
TZConnection1.Port :=5432;
TZConnection1.Password :=mypass;
TZConnection1.Properties.loadFormFile(myfile);
TZConnection1.Connect;

Regards

Edmilson

bitmapbrother
Fresh Boarder
Fresh Boarder
Posts: 8
Joined: 24.11.2005, 09:34
Contact:

Postby bitmapbrother » 06.12.2005, 16:01

my parameters should be ok - i am using them while connecting using native postgre api

klchin
Senior Boarder
Senior Boarder
Posts: 65
Joined: 02.09.2005, 06:27

Postby klchin » 12.12.2005, 12:33

Hi,


Hv u edit the pg_dba.conf to add the IP

and postgreSQL

listen_addresses = '*'

yohanip
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: 19.06.2009, 11:26
Location: Indonesia
Contact:

in case anyone need although the post was old.. :p

Postby yohanip » 19.06.2009, 11:34

you need to specify the database name on the parameter sets to ensure that the zeoslib to use the 'user' parameter


Return to “6.5.1 (alpha) - 6.6.x (beta)”

Who is online

Users browsing this forum: No registered users and 1 guest