Many problems coming from 7.1.4 (sqlite-3/lazarus)

The forum for ZeosLib 7.2 Report problems. Ask for help, post proposals for the new version and Zeoslib 7.2 features here. This is a forum that will be edited once the 7.2.x version goes into RC/stable!!

My personal intention for 7.2 is to speed up the internals as optimal a possible for all IDE's. Hope you can help?! Have fun with testing 7.2
olivluca
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 17.05.2018, 12:36

Many problems coming from 7.1.4 (sqlite-3/lazarus)

Postby olivluca » 17.05.2018, 12:45

Hello,
since I need some features in trunk, I tried both trunk and then 7.2 stable with my existing projects using sqlite-3.

The short version: they don't work anymore :(
  • if in a TZQuery/TZReadonlyQuery I use the already defined fields, I get a sigsev (sometimes when opening a query, sometime after posting a new record), probably because...
  • if I delete and recreate the fields now VARCHAR is mapped to TMemoField (previously it was TStringField) and DATETIME is mapped to TStringField (instead of TDateTimeField) :?:
  • when I delete a record I get this message "Cannot update a complex query with more than one table", it worked with 7.1.4, the query is "select rowid,* from modelos order by modelo,color,ak,ks", hardly complex and more than one table

I know I should have tested during the 7.2 beta, but I didn't (not enough time :( )

olivluca
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 17.05.2018, 12:36

Re: Many problems coming from 7.1.4 (sqlite-3/lazarus)

Postby olivluca » 17.05.2018, 21:37

Ok, the second problem is solved by adding a Undefined_Varchar_AsString_Length=xxx property (thanks to EgonHugeist who replied to my bug here).
Apparently this also solved the first problem (the SIGSEV).
The third problems is still pending, I opened this bug for it.

Edit: link to second bug corrected


Return to “ZeosLib 7.2 Forum”

Who is online

Users browsing this forum: No registered users and 0 guests